aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 9f2731ddaa..6f509741ac 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -83,6 +83,13 @@ define Build/asus-trx
mv $@.new $@
endef
+define Build/luxul-lxl
+ $(STAGING_DIR_HOST)/bin/lxlfw create $@.new \
+ -i $@ \
+ -b $(LUXUL_BOARD)
+ mv $@.new $@
+endef
+
define Build/seama-nand
# Seama entity
$(STAGING_DIR_HOST)/bin/oseama \
@@ -102,6 +109,7 @@ endef
DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION TPLINK_BOARD
DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
+DEVICE_VARS += LUXUL_BOARD
IEEE8021X := wpad-basic
B43 := $(IEEE8021X) kmod-b43
@@ -262,6 +270,28 @@ define Device/linksys-ea9500
endef
# TARGET_DEVICES += linksys-ea9500
+define Device/luxul
+ DEVICE_VENDOR := Luxul
+ IMAGES := lxl
+ IMAGE/lxl := append-ubi | trx-nand | luxul-lxl
+endef
+
+define Device/luxul-abr-4500
+ $(Device/luxul)
+ DEVICE_MODEL := ABR-4500
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
+ LUXUL_BOARD := ABR-4500
+endef
+TARGET_DEVICES += luxul-abr-4500
+
+define Device/luxul-xbr-4500
+ $(Device/luxul)
+ DEVICE_MODEL := XBR-4500
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
+ LUXUL_BOARD := XBR-4500
+endef
+TARGET_DEVICES += luxul-xbr-4500
+
define Device/netgear
DEVICE_VENDOR := NETGEAR
IMAGES := chk