aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 7aa9fc2a3a..c9987dddc7 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -87,6 +87,18 @@ define AsusDevice
TARGET_DEVICES += asus-$(1)
endef
+define Device/linksys
+ IMAGES := trx
+ IMAGE/trx := trx-nand
+endef
+
+define LinksysDevice
+ define Device/linksys-$(1)
+ $$(Device/linksys)
+ endef
+ TARGET_DEVICES += linksys-$(1)
+endef
+
define Device/netgear
IMAGES := chk
IMAGE/chk := trx-nand | netgear-chk
@@ -131,6 +143,7 @@ $(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
$(eval $(call AsusDevice,rt-n18u,RT-N18U))
+$(eval $(call LinksysDevice,ea6300-v1))
$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
$(eval $(call BuildImage))