aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm4908/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm4908/Makefile')
-rw-r--r--target/linux/bcm4908/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/bcm4908/Makefile b/target/linux/bcm4908/Makefile
new file mode 100644
index 0000000000..d5f82a188e
--- /dev/null
+++ b/target/linux/bcm4908/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=bcm4908
+BOARDNAME:=Broadcom BCM4908 (ARMv8A CPUs Brahma-B53)
+FEATURES:=squashfs nand usb pci pcie gpio source-only
+CPU_TYPE:=cortex-a53
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
+
+define Target/Description
+ Build firmware images for Broadcom BCM4908 SoC family routers.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))