aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.4/950-0890-dtoverlays-Create-an-overlay-for-the-Omnivision-OV72.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/patches-5.4/950-0890-dtoverlays-Create-an-overlay-for-the-Omnivision-OV72.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.4/950-0890-dtoverlays-Create-an-overlay-for-the-Omnivision-OV72.patch157
1 files changed, 0 insertions, 157 deletions
diff --git a/target/linux/bcm27xx/patches-5.4/950-0890-dtoverlays-Create-an-overlay-for-the-Omnivision-OV72.patch b/target/linux/bcm27xx/patches-5.4/950-0890-dtoverlays-Create-an-overlay-for-the-Omnivision-OV72.patch
deleted file mode 100644
index 6a4da8f814..0000000000
--- a/target/linux/bcm27xx/patches-5.4/950-0890-dtoverlays-Create-an-overlay-for-the-Omnivision-OV72.patch
+++ /dev/null
@@ -1,157 +0,0 @@
-From 870de3bc0e80a9b79b470a45636437a0078041c1 Mon Sep 17 00:00:00 2001
-From: Dave Stevenson <dave.stevenson@raspberrypi.com>
-Date: Tue, 7 Jul 2020 16:12:05 +0100
-Subject: [PATCH] dtoverlays: Create an overlay for the Omnivision
- OV7251 sensor
-
-Adds an overlay for the OV7251 VGA global shutter sensor.
-
-Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.com>
----
- arch/arm/boot/dts/overlays/Makefile | 1 +
- arch/arm/boot/dts/overlays/README | 8 ++
- arch/arm/boot/dts/overlays/ov7251-overlay.dts | 111 ++++++++++++++++++
- 3 files changed, 120 insertions(+)
- create mode 100644 arch/arm/boot/dts/overlays/ov7251-overlay.dts
-
---- a/arch/arm/boot/dts/overlays/Makefile
-+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -115,6 +115,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
- mpu6050.dtbo \
- mz61581.dtbo \
- ov5647.dtbo \
-+ ov7251.dtbo \
- ov9281.dtbo \
- papirus.dtbo \
- pibell.dtbo \
---- a/arch/arm/boot/dts/overlays/README
-+++ b/arch/arm/boot/dts/overlays/README
-@@ -1813,6 +1813,14 @@ Load: dtoverlay=ov5647
- Params: <None>
-
-
-+Name: ov7251
-+Info: Omnivision OV7251 camera module.
-+ Uses Unicam 1, which is the standard camera connector on most Pi
-+ variants.
-+Load: dtoverlay=ov7251
-+Params: <None>
-+
-+
- Name: ov9281
- Info: Omnivision OV9281 camera module.
- Uses Unicam 1, which is the standard camera connector on most Pi
---- /dev/null
-+++ b/arch/arm/boot/dts/overlays/ov7251-overlay.dts
-@@ -0,0 +1,111 @@
-+// SPDX-License-Identifier: GPL-2.0-only
-+// Definitions for OV7251 camera module on VC I2C bus
-+/dts-v1/;
-+/plugin/;
-+
-+#include <dt-bindings/gpio/gpio.h>
-+
-+/{
-+ compatible = "brcm,bcm2835";
-+
-+ fragment@0 {
-+ target = <&i2c_csi_dsi>;
-+ __overlay__ {
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+ status = "okay";
-+
-+ ov7251: ov7251@60 {
-+ compatible = "ovti,ov7251";
-+ reg = <0x60>;
-+ status = "okay";
-+
-+ clocks = <&ov7251_clk>;
-+ clock-names = "xclk";
-+ clock-frequency = <24000000>;
-+
-+ vdddo-supply = <&ov7251_dovdd>;
-+ vdda-supply = <&ov7251_avdd>;
-+ vddd-supply = <&ov7251_dvdd>;
-+
-+ enable-gpios = <&gpio 41 GPIO_ACTIVE_HIGH>;
-+
-+ port {
-+ ov7251_0: endpoint {
-+ remote-endpoint = <&csi1_ep>;
-+ clock-lanes = <0>;
-+ data-lanes = <1>;
-+ clock-noncontinuous;
-+ link-frequencies =
-+ /bits/ 64 <456000000>;
-+ };
-+ };
-+ };
-+ };
-+ };
-+
-+ fragment@1 {
-+ target = <&csi1>;
-+ __overlay__ {
-+ status = "okay";
-+
-+ port {
-+ csi1_ep: endpoint {
-+ remote-endpoint = <&ov7251_0>;
-+ data-lanes = <1>;
-+ };
-+ };
-+ };
-+ };
-+
-+ fragment@2 {
-+ target = <&i2c0if>;
-+ __overlay__ {
-+ status = "okay";
-+ };
-+ };
-+
-+ fragment@3 {
-+ target-path="/";
-+ __overlay__ {
-+ ov7251_avdd: fixedregulator@0 {
-+ compatible = "regulator-fixed";
-+ regulator-name = "ov7251_avdd";
-+ regulator-min-microvolt = <2800000>;
-+ regulator-max-microvolt = <2800000>;
-+ };
-+ ov7251_dovdd: fixedregulator@1 {
-+ compatible = "regulator-fixed";
-+ regulator-name = "ov7251_dovdd";
-+ regulator-min-microvolt = <1800000>;
-+ regulator-max-microvolt = <1800000>;
-+ };
-+ ov7251_dvdd: fixedregulator@2 {
-+ compatible = "regulator-fixed";
-+ regulator-name = "ov7251_dvdd";
-+ regulator-min-microvolt = <1200000>;
-+ regulator-max-microvolt = <1200000>;
-+ };
-+ ov7251_clk: ov7251-clk {
-+ compatible = "fixed-clock";
-+ #clock-cells = <0>;
-+ clock-frequency = <24000000>;
-+ };
-+ };
-+ };
-+
-+ fragment@4 {
-+ target = <&i2c0mux>;
-+ __overlay__ {
-+ status = "okay";
-+ };
-+ };
-+
-+ fragment@5 {
-+ target-path="/__overrides__";
-+ __overlay__ {
-+ cam0-pwdn-ctrl = <&ov7251>,"enable-gpios:0";
-+ cam0-pwdn = <&ov7251>,"enable-gpios:4";
-+ };
-+ };
-+};