aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.4/950-0313-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/patches-5.4/950-0313-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.4/950-0313-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/patches-5.4/950-0313-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch b/target/linux/bcm27xx/patches-5.4/950-0313-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
new file mode 100644
index 0000000000..d36f3eb802
--- /dev/null
+++ b/target/linux/bcm27xx/patches-5.4/950-0313-kbuild-Allow-.dtbo-overlays-to-be-built-piecemeal.patch
@@ -0,0 +1,36 @@
+From 7542fb08d2726606057c4283b3a454abb195a0f5 Mon Sep 17 00:00:00 2001
+From: Phil Elwell <phil@raspberrypi.org>
+Date: Mon, 23 Sep 2019 09:26:41 +0100
+Subject: [PATCH] kbuild: Allow .dtbo overlays to be built piecemeal
+
+Before 4.20, it was possible to build an arbitrary overlay by copying
+it to arm/boot/dts/overlays/mytest-overlay.dts and running:
+
+ make ARCH=arm overlays/mytest.dtbo
+
+In 4.20 the .dtb build rules were centralised, requiring the dowstream
+.dtbo build rules to be changed. They were, enough to support "make ...
+dtbs", but not sufficiently to allow this ad-hoc, one-off building of
+individual files.
+
+Add the missing makefile rule to support this way of building.
+
+See: https://github.com/raspberrypi/linux/issues/3250
+
+Signed-off-by: Phil Elwell <phil@raspberrypi.org>
+---
+ Makefile | 3 +++
+ 1 file changed, 3 insertions(+)
+
+--- a/Makefile
++++ b/Makefile
+@@ -1261,6 +1261,9 @@ ifneq ($(dtstree),)
+ %.dtb: include/config/kernel.release scripts_dtc
+ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
+
++%.dtbo: prepare3 scripts_dtc
++ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
++
+ PHONY += dtbs dtbs_install dtbs_check
+ dtbs: include/config/kernel.release scripts_dtc
+ $(Q)$(MAKE) $(build)=$(dtstree)