aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.15/950-0523-overlays-Add-imx519-overlay.dts.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/patches-5.15/950-0523-overlays-Add-imx519-overlay.dts.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.15/950-0523-overlays-Add-imx519-overlay.dts.patch164
1 files changed, 164 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/patches-5.15/950-0523-overlays-Add-imx519-overlay.dts.patch b/target/linux/bcm27xx/patches-5.15/950-0523-overlays-Add-imx519-overlay.dts.patch
new file mode 100644
index 0000000000..bf13523b6a
--- /dev/null
+++ b/target/linux/bcm27xx/patches-5.15/950-0523-overlays-Add-imx519-overlay.dts.patch
@@ -0,0 +1,164 @@
+From d8faff7e7581ee3417675e2f64da18ffb831751a Mon Sep 17 00:00:00 2001
+From: Lee Jackson <info@arducam.com>
+Date: Fri, 27 Aug 2021 14:45:43 +0800
+Subject: [PATCH] overlays: Add imx519-overlay.dts
+
+Added overlays for enabling IMX519 and add the
+relevant information to the README.
+
+Signed-off-by: Lee Jackson <info@arducam.com>
+---
+ arch/arm/boot/dts/overlays/Makefile | 1 +
+ arch/arm/boot/dts/overlays/README | 11 ++
+ arch/arm/boot/dts/overlays/imx519-overlay.dts | 115 ++++++++++++++++++
+ 3 files changed, 127 insertions(+)
+ create mode 100644 arch/arm/boot/dts/overlays/imx519-overlay.dts
+
+--- a/arch/arm/boot/dts/overlays/Makefile
++++ b/arch/arm/boot/dts/overlays/Makefile
+@@ -98,6 +98,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
+ imx290.dtbo \
+ imx378.dtbo \
+ imx477.dtbo \
++ imx519.dtbo \
+ iqaudio-codec.dtbo \
+ iqaudio-dac.dtbo \
+ iqaudio-dacplus.dtbo \
+--- a/arch/arm/boot/dts/overlays/README
++++ b/arch/arm/boot/dts/overlays/README
+@@ -1738,6 +1738,17 @@ Params: rotation Mounting
+ 2 = external, default external)
+
+
++Name: imx519
++Info: Sony IMX519 camera module.
++ Uses Unicam 1, which is the standard camera connector on most Pi
++ variants.
++Load: dtoverlay=imx519,<param>=<val>
++Params: rotation Mounting rotation of the camera sensor (0 or
++ 180, default 0)
++ orientation Sensor orientation (0 = front, 1 = rear,
++ 2 = external, default external)
++
++
+ Name: iqaudio-codec
+ Info: Configures the IQaudio Codec audio card
+ Load: dtoverlay=iqaudio-codec
+--- /dev/null
++++ b/arch/arm/boot/dts/overlays/imx519-overlay.dts
+@@ -0,0 +1,115 @@
++// SPDX-License-Identifier: GPL-2.0-only
++// Definitions for imx519 camera module on VC I2C bus
++/dts-v1/;
++/plugin/;
++
++#include <dt-bindings/gpio/gpio.h>
++
++/{
++ compatible = "brcm,bcm2835";
++
++ fragment@0 {
++ target = <&i2c_csi_dsi>;
++ __overlay__ {
++ #address-cells = <1>;
++ #size-cells = <0>;
++ status = "okay";
++
++ imx519: imx519@1a {
++ compatible = "sony,imx519";
++ reg = <0x1a>;
++ status = "okay";
++
++ clocks = <&imx519_clk>;
++ clock-names = "xclk";
++
++ VANA-supply = <&cam1_reg>; /* 2.8v */
++ VDIG-supply = <&imx519_vdig>; /* 1.8v */
++ VDDL-supply = <&imx519_vddl>; /* 1.2v */
++
++ rotation = <0>;
++ orientation = <2>;
++
++ port {
++ imx519_0: endpoint {
++ remote-endpoint = <&csi1_ep>;
++ clock-lanes = <0>;
++ data-lanes = <1 2>;
++ clock-noncontinuous;
++ link-frequencies =
++ /bits/ 64 <493500000>;
++ };
++ };
++ };
++ };
++ };
++
++ fragment@1 {
++ target = <&csi1>;
++ __overlay__ {
++ status = "okay";
++
++ port{
++ csi1_ep: endpoint{
++ remote-endpoint = <&imx519_0>;
++ clock-lanes = <0>;
++ data-lanes = <1 2>;
++ clock-noncontinuous;
++ };
++ };
++ };
++ };
++
++ fragment@2 {
++ target = <&i2c0if>;
++ __overlay__ {
++ status = "okay";
++ };
++ };
++
++ fragment@3 {
++ target-path="/";
++ __overlay__ {
++ imx519_vdig: fixedregulator@1 {
++ compatible = "regulator-fixed";
++ regulator-name = "imx519_vdig";
++ regulator-min-microvolt = <1800000>;
++ regulator-max-microvolt = <1800000>;
++ };
++ imx519_vddl: fixedregulator@2 {
++ compatible = "regulator-fixed";
++ regulator-name = "imx519_vddl";
++ regulator-min-microvolt = <1200000>;
++ regulator-max-microvolt = <1200000>;
++ };
++
++ imx519_clk: camera-clk {
++ compatible = "fixed-clock";
++ #clock-cells = <0>;
++ clock-frequency = <24000000>;
++ };
++ };
++ };
++
++ fragment@4 {
++ target = <&i2c0mux>;
++ __overlay__ {
++ status = "okay";
++ };
++ };
++
++ fragment@5 {
++ target = <&cam1_reg>;
++ __overlay__ {
++ status = "okay";
++ regulator-name = "imx519_vana";
++ regulator-min-microvolt = <2800000>;
++ regulator-max-microvolt = <2800000>;
++ };
++ };
++
++ __overrides__ {
++ rotation = <&imx519>,"rotation:0";
++ orientation = <&imx519>,"orientation:0";
++ };
++};