aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.10/950-0738-Makefiles-dt-Always-set-on-ARCH_BCM2835.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/patches-5.10/950-0738-Makefiles-dt-Always-set-on-ARCH_BCM2835.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0738-Makefiles-dt-Always-set-on-ARCH_BCM2835.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/patches-5.10/950-0738-Makefiles-dt-Always-set-on-ARCH_BCM2835.patch b/target/linux/bcm27xx/patches-5.10/950-0738-Makefiles-dt-Always-set-on-ARCH_BCM2835.patch
new file mode 100644
index 0000000000..0cb30474b5
--- /dev/null
+++ b/target/linux/bcm27xx/patches-5.10/950-0738-Makefiles-dt-Always-set-on-ARCH_BCM2835.patch
@@ -0,0 +1,35 @@
+From 72d78ec8b6898976ea46b1c0cb9780707985cd80 Mon Sep 17 00:00:00 2001
+From: Phil Elwell <phil@raspberrypi.com>
+Date: Thu, 19 Aug 2021 14:28:56 +0100
+Subject: [PATCH] Makefiles: dt: Always set '-@' on ARCH_BCM2835
+
+On the BCM2835 architecture, always add the '-@' option to enable the
+generation of symbols, rather than relying on DTC_FLAGS being empty
+or correct.
+
+See: https://github.com/raspberrypi/linux/issues/3846
+
+Signed-off-by: Phil Elwell <phil@raspberrypi.com>
+---
+ arch/arm/boot/dts/Makefile | 2 +-
+ arch/arm64/boot/dts/broadcom/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -1432,5 +1432,5 @@ subdir-y := overlays
+
+ # Enable fixups to support overlays on BCM2835 platforms
+ ifeq ($(CONFIG_ARCH_BCM2835),y)
+- DTC_FLAGS ?= -@
++ DTC_FLAGS += -@
+ endif
+--- a/arch/arm64/boot/dts/broadcom/Makefile
++++ b/arch/arm64/boot/dts/broadcom/Makefile
+@@ -16,5 +16,5 @@ subdir-y += stingray
+
+ # Enable fixups to support overlays on BCM2835 platforms
+ ifeq ($(CONFIG_ARCH_BCM2835),y)
+- DTC_FLAGS ?= -@
++ DTC_FLAGS += -@
+ endif