aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.10/950-0623-overlays-Add-rpi-poe-plus-overlay.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/patches-5.10/950-0623-overlays-Add-rpi-poe-plus-overlay.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0623-overlays-Add-rpi-poe-plus-overlay.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/patches-5.10/950-0623-overlays-Add-rpi-poe-plus-overlay.patch b/target/linux/bcm27xx/patches-5.10/950-0623-overlays-Add-rpi-poe-plus-overlay.patch
new file mode 100644
index 0000000000..67b69d85d0
--- /dev/null
+++ b/target/linux/bcm27xx/patches-5.10/950-0623-overlays-Add-rpi-poe-plus-overlay.patch
@@ -0,0 +1,75 @@
+From 022c80564d30bba83b82a0ccdff74648e47862dd Mon Sep 17 00:00:00 2001
+From: Serge Schneider <serge@raspberrypi.com>
+Date: Mon, 2 Dec 2019 14:48:05 +0000
+Subject: [PATCH] overlays: Add rpi-poe-plus overlay
+
+Signed-off-by: Serge Schneider <serge@raspberrypi.com>
+---
+ arch/arm/boot/dts/overlays/Makefile | 1 +
+ arch/arm/boot/dts/overlays/README | 21 +++++++++++++++++++
+ .../dts/overlays/rpi-poe-plus-overlay.dts | 19 +++++++++++++++++
+ 3 files changed, 41 insertions(+)
+ create mode 100644 arch/arm/boot/dts/overlays/rpi-poe-plus-overlay.dts
+
+--- a/arch/arm/boot/dts/overlays/Makefile
++++ b/arch/arm/boot/dts/overlays/Makefile
+@@ -156,6 +156,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
+ rpi-display.dtbo \
+ rpi-ft5406.dtbo \
+ rpi-poe.dtbo \
++ rpi-poe-plus.dtbo \
+ rpi-proto.dtbo \
+ rpi-sense.dtbo \
+ rpi-tv.dtbo \
+--- a/arch/arm/boot/dts/overlays/README
++++ b/arch/arm/boot/dts/overlays/README
+@@ -2505,6 +2505,27 @@ Params: poe_fan_temp0 Temperat
+ the fan slows down (default 5000)
+
+
++Name: rpi-poe-plus
++Info: Raspberry Pi PoE+ HAT fan
++Load: dtoverlay=rpi-poe-plus,<param>[=<val>]
++Params: poe_fan_temp0 Temperature (in millicelcius) at which the fan
++ turns on (default 40000)
++ poe_fan_temp0_hyst Temperature delta (in millicelcius) at which
++ the fan turns off (default 2000)
++ poe_fan_temp1 Temperature (in millicelcius) at which the fan
++ speeds up (default 45000)
++ poe_fan_temp1_hyst Temperature delta (in millicelcius) at which
++ the fan slows down (default 2000)
++ poe_fan_temp2 Temperature (in millicelcius) at which the fan
++ speeds up (default 50000)
++ poe_fan_temp2_hyst Temperature delta (in millicelcius) at which
++ the fan slows down (default 2000)
++ poe_fan_temp3 Temperature (in millicelcius) at which the fan
++ speeds up (default 55000)
++ poe_fan_temp3_hyst Temperature delta (in millicelcius) at which
++ the fan slows down (default 5000)
++
++
+ Name: rpi-proto
+ Info: Configures the RPi Proto audio card
+ Load: dtoverlay=rpi-proto
+--- /dev/null
++++ b/arch/arm/boot/dts/overlays/rpi-poe-plus-overlay.dts
+@@ -0,0 +1,19 @@
++// SPDX-License-Identifier: (GPL-2.0 OR MIT)
++// Overlay for the Raspberry Pi PoE+ HAT.
++
++#include "rpi-poe-overlay.dts"
++
++/ {
++ compatible = "brcm,bcm2835";
++
++ fragment@3 {
++ target-path = "/";
++ __overlay__ {
++ rpi_poe_power_supply: rpi-poe-power-supply@0 {
++ compatible = "raspberrypi,rpi-poe-power-supply";
++ firmware = <&firmware>;
++ status = "okay";
++ };
++ };
++ };
++};