aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch')
-rw-r--r--target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch100
1 files changed, 0 insertions, 100 deletions
diff --git a/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch b/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch
deleted file mode 100644
index 35405ee137..0000000000
--- a/target/linux/bcm27xx/patches-5.10/950-0518-overlays-Add-minipitft13-overlay.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 6c6596610381249719e87e324a9689cabc2a7cd8 Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.com>
-Date: Thu, 18 Feb 2021 21:05:44 +0000
-Subject: [PATCH] overlays: Add minipitft13 overlay
-
-minipitft13 is an overlay for the Adafruit 1.3" 240x240 display
-(code 4484).
-
-See: https://github.com/raspberrypi/firmware/issues/1524
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.com>
----
- arch/arm/boot/dts/overlays/Makefile | 1 +
- .../boot/dts/overlays/minipitft13-overlay.dts | 70 +++++++++++++++++++
- 2 files changed, 71 insertions(+)
- create mode 100644 arch/arm/boot/dts/overlays/minipitft13-overlay.dts
-
---- a/arch/arm/boot/dts/overlays/Makefile
-+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -119,6 +119,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
- merus-amp.dtbo \
- midi-uart0.dtbo \
- midi-uart1.dtbo \
-+ minipitft13.dtbo \
- miniuart-bt.dtbo \
- mmc.dtbo \
- mpu6050.dtbo \
---- /dev/null
-+++ b/arch/arm/boot/dts/overlays/minipitft13-overlay.dts
-@@ -0,0 +1,70 @@
-+/*
-+ * Device Tree overlay for Adafruit Mini PiTFT 1.3" and 1.5" 240x240 Display
-+ *
-+ */
-+
-+/dts-v1/;
-+/plugin/;
-+
-+/ {
-+ compatible = "brcm,bcm2835";
-+
-+ fragment@0 {
-+ target = <&spi0>;
-+ __overlay__ {
-+ status = "okay";
-+
-+ spidev@0{
-+ status = "disabled";
-+ };
-+
-+ spidev@1{
-+ status = "disabled";
-+ };
-+ };
-+ };
-+
-+ fragment@1 {
-+ target = <&gpio>;
-+ __overlay__ {
-+ pitft_pins: pitft_pins {
-+ brcm,pins = <25>;
-+ brcm,function = <1>; /* out */
-+ brcm,pull = <0>; /* none */
-+ };
-+ };
-+ };
-+
-+ fragment@2 {
-+ target = <&spi0>;
-+ __overlay__ {
-+ /* needed to avoid dtc warning */
-+ #address-cells = <1>;
-+ #size-cells = <0>;
-+
-+ pitft: pitft@0 {
-+ compatible = "fbtft,minipitft13";
-+ reg = <0>;
-+ pinctrl-names = "default";
-+ pinctrl-0 = <&pitft_pins>;
-+ spi-max-frequency = <32000000>;
-+ rotate = <0>;
-+ width = <240>;
-+ height = <240>;
-+ buswidth = <8>;
-+ dc-gpios = <&gpio 25 0>;
-+ led-gpios = <&gpio 26 0>;
-+ debug = <0>;
-+ };
-+ };
-+ };
-+
-+ __overrides__ {
-+ speed = <&pitft>,"spi-max-frequency:0";
-+ rotate = <&pitft>,"rotate:0";
-+ width = <&pitft>,"width:0";
-+ height = <&pitft>,"height:0";
-+ fps = <&pitft>,"fps:0";
-+ debug = <&pitft>,"debug:0";
-+ };
-+};