aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/modules/sound.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/modules/sound.mk')
-rw-r--r--target/linux/bcm27xx/modules/sound.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/modules/sound.mk b/target/linux/bcm27xx/modules/sound.mk
index dab31d8132..5073e5ff50 100644
--- a/target/linux/bcm27xx/modules/sound.mk
+++ b/target/linux/bcm27xx/modules/sound.mk
@@ -365,6 +365,26 @@ endef
$(eval $(call KernelPackage,sound-soc-audioinjector-pi-soundcard))
+define KernelPackage/sound-soc-chipdip-dac
+ TITLE:=Support for ChipDip DAC
+ KCONFIG:= \
+ CONFIG_SND_BCM2708_SOC_CHIPDIP_DAC
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/bcm/snd-soc-chipdip-dac.ko
+ AUTOLOAD:=$(call AutoLoad,68,snd-soc-chipdip-dac)
+ DEPENDS:= \
+ kmod-sound-soc-bcm2835-i2s \
+ @LINUX_5_10
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-chipdip-dac/description
+ This package contains support for ChipDip DAC
+endef
+
+$(eval $(call KernelPackage,sound-soc-chipdip-dac))
+
+
define KernelPackage/sound-soc-digidac1-soundcard
TITLE:=Support for RRA DigiDAC1
KCONFIG:= \