aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/Makefile')
-rw-r--r--target/linux/bcm27xx/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/bcm27xx/Makefile b/target/linux/bcm27xx/Makefile
new file mode 100644
index 0000000000..8976a43609
--- /dev/null
+++ b/target/linux/bcm27xx/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2012-2019 OpenWrt.org
+# Copyright (C) 2017 LEDE project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=bcm27xx
+BOARDNAME:=Broadcom BCM27xx
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part boot-part
+MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+SUBTARGETS:=bcm2708 bcm2709 bcm2710 bcm2711
+
+KERNEL_PATCHVER:=4.19
+
+define Target/Description
+ Build firmware image for Broadcom BCM27xx SoC devices.
+ Currently produces SD Card image for Raspberry Pi.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ bcm27xx-gpu-fw \
+ kmod-usb-hid \
+ kmod-sound-core kmod-sound-arm-bcm2835 \
+ kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
+ partx-utils mkf2fs e2fsprogs
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))