aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32-2.6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/avr32-2.6/Makefile')
-rw-r--r--target/linux/avr32-2.6/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/avr32-2.6/Makefile b/target/linux/avr32-2.6/Makefile
new file mode 100644
index 0000000000..2dcd76a9b4
--- /dev/null
+++ b/target/linux/avr32-2.6/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=avr32
+BOARD:=avr32
+BOARDNAME:=Atmel AVR32
+FEATURES:=squashfs
+
+define Target/Description
+ Build firmware images for ATNGW100 board
+endef
+
+KERNEL:=2.6
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+#include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))