aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000-2.6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/au1000-2.6/Makefile')
-rw-r--r--target/linux/au1000-2.6/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/au1000-2.6/Makefile b/target/linux/au1000-2.6/Makefile
index 8c1c67d183..8ba22aa683 100644
--- a/target/linux/au1000-2.6/Makefile
+++ b/target/linux/au1000-2.6/Makefile
@@ -1,8 +1,8 @@
include $(TOPDIR)/rules.mk
-LINUX_VERSION:=2.6.16.4
+LINUX_VERSION:=2.6.16.7
LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=cb675279c9711237a06ebb8379a4da27
+LINUX_KERNEL_MD5SUM:=9682b2bd6e02f3087982d7c3f5ba824e
include ../rules.mk
include ./config
@@ -17,9 +17,10 @@ $(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
@$(CP) config $(LINUX_DIR)/.config
touch $@
-$(LINUX_BUILD_DIR)/bzImage: $(LINUX_DIR)/vmlinux
- $(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) bzImage
- $(CP) $(LINUX_DIR)/vmlinux $@
+$(LINUX_BUILD_DIR)/zImage.flash.srec: $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec
+ $(MAKE) -C $(LINUX_DIR) V=1 CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) zImage.flash
+ $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
+ $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
touch $@
compile: $(LINUX_DIR)/vmlinux