aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch')
-rw-r--r--target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch24
1 files changed, 8 insertions, 16 deletions
diff --git a/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch b/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
index 5f41656d1b..f9906516d9 100644
--- a/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
+++ b/target/linux/ath79/patches-4.14/0026-MIPS-ath79-sanitize-Kconfig-symbols.patch
@@ -11,10 +11,8 @@ Signed-off-by: John Crispin <john@phrozen.org>
arch/mips/pci/Makefile | 2 +-
4 files changed, 8 insertions(+), 54 deletions(-)
-Index: linux-4.14.18/arch/mips/Kconfig
-===================================================================
---- linux-4.14.18.orig/arch/mips/Kconfig
-+++ linux-4.14.18/arch/mips/Kconfig
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
@@ -203,6 +203,8 @@ config ATH79
select SYS_SUPPORTS_BIG_ENDIAN
select SYS_SUPPORTS_MIPS16
@@ -24,10 +22,8 @@ Index: linux-4.14.18/arch/mips/Kconfig
select USE_OF
help
Support for the Atheros AR71XX/AR724X/AR913X SoCs.
-Index: linux-4.14.18/arch/mips/ath79/Kconfig
-===================================================================
---- linux-4.14.18.orig/arch/mips/ath79/Kconfig
-+++ linux-4.14.18/arch/mips/ath79/Kconfig
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
@@ -1,52 +1,14 @@
# SPDX-License-Identifier: GPL-2.0
if ATH79
@@ -86,10 +82,8 @@ Index: linux-4.14.18/arch/mips/ath79/Kconfig
def_bool n
endif
-Index: linux-4.14.18/arch/mips/ath79/Makefile
-===================================================================
---- linux-4.14.18.orig/arch/mips/ath79/Makefile
-+++ linux-4.14.18/arch/mips/ath79/Makefile
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
@@ -11,13 +11,3 @@
obj-y := prom.o setup.o common.o clock.o
@@ -104,10 +98,8 @@ Index: linux-4.14.18/arch/mips/ath79/Makefile
-obj-$(CONFIG_ATH79_DEV_SPI) += dev-spi.o
-obj-$(CONFIG_ATH79_DEV_USB) += dev-usb.o
-obj-$(CONFIG_ATH79_DEV_WMAC) += dev-wmac.o
-Index: linux-4.14.18/arch/mips/pci/Makefile
-===================================================================
---- linux-4.14.18.orig/arch/mips/pci/Makefile
-+++ linux-4.14.18/arch/mips/pci/Makefile
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
@@ -23,7 +23,7 @@ obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o
ops-bcm63xx.o
obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o