aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/modules.mk')
-rw-r--r--target/linux/ath79/modules.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/modules.mk b/target/linux/ath79/modules.mk
new file mode 100644
index 0000000000..946440dd61
--- /dev/null
+++ b/target/linux/ath79/modules.mk
@@ -0,0 +1,16 @@
+LEDS_MENU:=LED modules
+
+define KernelPackage/leds-reset
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=reset controller LED support
+ DEPENDS:= @TARGET_ath79
+ KCONFIG:=CONFIG_LEDS_RESET=m
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-reset.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-reset,1)
+endef
+
+define KernelPackage/leds-reset/description
+ Kernel module for LEDs on reset lines
+endef
+
+$(eval $(call KernelPackage,leds-reset))