aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/Makefile8
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk24
-rw-r--r--target/linux/ath79/image/generic.mk25
3 files changed, 33 insertions, 24 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 768ec57044..32a4b2abed 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -8,14 +8,6 @@ DEVICE_VARS += LOADER_FLASH_MAX LOADER_KERNEL_MAGIC
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
-define Build/combined-image
- sh $(TOPDIR)/scripts/combined-image.sh \
- "$(IMAGE_KERNEL)" \
- "$@" \
- "$@.new"
- @mv $@.new $@
-endef
-
define Build/loader-common
rm -rf $@.src
$(MAKE) -C lzma-loader \
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 2381d92567..cb7a6417b0 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -394,14 +394,24 @@ define Device/ubnt_routerstation_common
kmod-usb2 fconfig
DEVICE_VENDOR := Ubiquiti
SOC := ar7161
- IMAGE_SIZE := 16128k
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x50000
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile | lzma | pad-to 128k
+ IMAGE_SIZE := 16000k
IMAGES += factory.bin
- IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | \
- check-size
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | \
- check-size | append-metadata
- KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
+ IMAGE/factory.bin := append-kernel | uImage lzma -M 0x4f4b4c49 | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | \
+ mkubntimage $$$$(KDIR)/loader-$(1).bin | check-size
+ IMAGE/sysupgrade.bin := append-kernel | uImage lzma -M 0x4f4b4c49 | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | check-size | \
+ sysupgrade-tar kernel=$$$$(KDIR)/loader-$(1).bin rootfs=$$$$@ | append-metadata
+ KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := Partition design has changed compared to older versions (19.07 and 21.02) \
+ due to kernel drivers restrictions. Upgrade via sysupgrade mechanism is one way operation. \
+ Downgrading OpenWrt version will involve usage of TFTP recovery or bootloader command line interface.
endef
define Device/ubnt_routerstation
@@ -411,7 +421,6 @@ define Device/ubnt_routerstation
UBNT_TYPE := RSx
UBNT_CHIP := ar7100
DEVICE_PACKAGES += -swconfig
- SUPPORTED_DEVICES += routerstation
endef
TARGET_DEVICES += ubnt_routerstation
@@ -421,7 +430,6 @@ define Device/ubnt_routerstation-pro
UBNT_BOARD := RSPRO
UBNT_TYPE := RSPRO
UBNT_CHIP := ar7100pro
- SUPPORTED_DEVICES += routerstation-pro
endef
TARGET_DEVICES += ubnt_routerstation-pro
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index c4b810cb59..2b81690654 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1454,15 +1454,24 @@ define Device/jjplus_ja76pf2
DEVICE_VENDOR := jjPlus
DEVICE_MODEL := JA76PF2
DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-basic-wolfssl -uboot-envtools fconfig
- IMAGES += kernel.bin rootfs.bin
- IMAGE/kernel.bin := append-kernel
- IMAGE/rootfs.bin := append-rootfs | pad-rootfs
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | \
- check-size | append-metadata
- KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x60000
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile | lzma | pad-to 128k
+ ARTIFACTS := loader.bin
+ ARTIFACT/loader.bin := append-loader-okli $(1)
+ IMAGES += firmware.bin
+ IMAGE/firmware.bin := append-kernel | uImage lzma -M 0x4f4b4c49 | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | check-size
+ IMAGE/sysupgrade.bin := $$(IMAGE/firmware.bin) | \
+ sysupgrade-tar kernel=$$$$(KDIR)/loader-$(1).bin rootfs=$$$$@ | append-metadata
+ KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb
- IMAGE_SIZE := 16000k
- SUPPORTED_DEVICES += ja76pf2
+ IMAGE_SIZE := 15872k
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := Partition design has changed compared to older versions (19.07 and 21.02) \
+ due to kernel drivers restrictions. Upgrade via sysupgrade mechanism is one way operation. \
+ Downgrading OpenWrt version will involve usage of bootloader command line interface.
endef
TARGET_DEVICES += jjplus_ja76pf2