aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index bb86c8b288..2d0b1adadb 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -63,6 +63,15 @@ define Device/ubnt-wa
ATH_SOC := ar9342
endef
+define Device/ubnt-xw
+ $(Device/ubnt)
+ UBNT_TYPE := XW
+ UBNT_CHIP := ar934x
+ UBNT_BOARD := XM
+ UBNT_VERSION := 6.0.4
+ ATH_SOC := ar9342
+endef
+
define Device/ubnt_bullet-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Bullet-M
@@ -70,6 +79,13 @@ define Device/ubnt_bullet-m
endef
TARGET_DEVICES += ubnt_bullet-m
+define Device/ubnt_bullet-m-xw
+ $(Device/ubnt-xw)
+ DEVICE_TITLE := Ubiquiti Bullet-M (XW)
+ SUPPORTED_DEVICES += bullet-m-xw
+endef
+TARGET_DEVICES += ubnt_bullet-m-xw
+
define Device/ubnt_rocket-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Rocket-M