aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index c946970818..467e2c4c42 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -28,6 +28,26 @@ define Device/tl-wr1043nd-v1
endef
TARGET_DEVICES += tl-wr1043nd-v1
+define Device/tl-wr1043nd-v2
+ $(Device/tplink-8mlzma)
+ ATH_SOC := qca9558
+ DEVICE_TITLE := TP-LINK TL-WR1043N/ND v2
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x10430002
+ SUPPORTED_DEVICES := tplink,tl-wr1043nd-v2 tl-wr1043nd-v2
+endef
+TARGET_DEVICES += tl-wr1043nd-v2
+
+define Device/tl-wr1043nd-v3
+ $(Device/tplink-8mlzma)
+ ATH_SOC := qca9558
+ DEVICE_TITLE := TP-LINK TL-WR1043N/ND v3
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+ TPLINK_HWID := 0x10430003
+ SUPPORTED_DEVICES := tplink,tl-wr1043nd-v3 tl-wr1043nd-v3
+endef
+TARGET_DEVICES += tl-wr1043nd-v3
+
define Device/tl-wr1043nd-v4
$(Device/tplink)
ATH_SOC := qca9563