aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/Makefile1
-rw-r--r--target/linux/ath79/image/tiny.mk18
2 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 15f4c1883a..734f27e689 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -75,6 +75,7 @@ ifeq ($(SUBTARGET),nand)
include ./nand.mk
endif
ifeq ($(SUBTARGET),tiny)
+include ./tiny.mk
include ./tiny-netgear.mk
include ./tiny-tp-link.mk
endif
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
new file mode 100644
index 0000000000..0a14fcdd5b
--- /dev/null
+++ b/target/linux/ath79/image/tiny.mk
@@ -0,0 +1,18 @@
+DEVICE_VARS += ROOTFS_SIZE
+
+define Device/buffalo_bhr-4grv2
+ ATH_SOC := qca9558
+ DEVICE_TITLE := Buffalo BHR-4GRV2
+ BOARDNAME := BHR-4GRV2
+ ROOTFS_SIZE := 14528k
+ KERNEL_SIZE := 1472k
+ IMAGE_SIZE := 16000k
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := \
+ append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | \
+ append-kernel | append-metadata | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := append-kernel | \
+ pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | mkbuffaloimg
+ SUPPORTED_DEVICES += bhr-4grv2
+endef
+TARGET_DEVICES += buffalo_bhr-4grv2