aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/tiny-netgear.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/tiny-netgear.mk')
-rw-r--r--target/linux/ath79/image/tiny-netgear.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-netgear.mk b/target/linux/ath79/image/tiny-netgear.mk
index b5fed1b88b..0df19390bb 100644
--- a/target/linux/ath79/image/tiny-netgear.mk
+++ b/target/linux/ath79/image/tiny-netgear.mk
@@ -28,6 +28,18 @@ define Device/on_n150r
endef
TARGET_DEVICES += on_n150r
+define Device/netgear_wnr1000-v2
+ ATH_SOC := ar7240
+ DEVICE_MODEL := WNR1000
+ DEVICE_VARIANT := v2
+ NETGEAR_KERNEL_MAGIC := 0x31303031
+ IMAGE_SIZE := 3712k
+ IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
+ SUPPORTED_DEVICES += wnr1000-v2
+ $(Device/netgear_ath79)
+endef
+TARGET_DEVICES += netgear_wnr1000-v2
+
define Device/netgear_wnr2000-v3
ATH_SOC := ar7241
DEVICE_MODEL := WNR2000