aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/nand.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/nand.mk')
-rw-r--r--target/linux/ath79/image/nand.mk12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index f7fc71d65e..420c62a5db 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -117,24 +117,15 @@ define Device/glinet_gl-ar750s-common
DEVICE_MODEL := GL-AR750S
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct kmod-usb2 \
kmod-usb-storage block-mount
- KERNEL_SIZE := 2048k
IMAGE_SIZE := 16000k
- PAGESIZE := 2048
- VID_HDR_OFFSET := 2048
endef
-# NB: The kernel size is intentionally restricted at this time; see commit message
define Device/glinet_gl-ar750s-nor-nand
$(Device/glinet_gl-ar750s-common)
DEVICE_VARIANT := NOR/NAND
- BLOCKSIZE := 128k
- GL_UBOOT_UBI_OFFSET := 2048k
- IMAGES += factory.img
- IMAGE/factory.img := append-kernel | pad-to $$$$(GL_UBOOT_UBI_OFFSET) | \
- append-ubi | check-kernel-size $$$$(GL_UBOOT_UBI_OFFSET)
+ KERNEL_SIZE := 4096k
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
SUPPORTED_DEVICES += glinet,gl-ar750s-nor
- DEFAULT := n
endef
TARGET_DEVICES += glinet_gl-ar750s-nor-nand
@@ -143,7 +134,6 @@ define Device/glinet_gl-ar750s-nor
DEVICE_VARIANT := NOR
BLOCKSIZE := 64k
SUPPORTED_DEVICES += gl-ar750s glinet,gl-ar750s glinet,gl-ar750s-nor-nand
- DEFAULT := n
endef
TARGET_DEVICES += glinet_gl-ar750s-nor