aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 1c2c805b2a..dc91e1b6d9 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1513,6 +1513,50 @@ define Device/qxwlan_e558-v2-8m
endef
TARGET_DEVICES += qxwlan_e558-v2-8m
+define Device/qxwlan_e600g-v2
+ SOC := qca9531
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E600G
+ DEVICE_PACKAGES := kmod-usb2
+ SUPPORTED_DEVICES += e600g-v2
+endef
+
+define Device/qxwlan_e600g-v2-16m
+ $(Device/qxwlan_e600g-v2)
+ DEVICE_VARIANT := v2 (16M)
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e600g-v2-16m
+
+define Device/qxwlan_e600g-v2-8m
+ $(Device/qxwlan_e600g-v2)
+ DEVICE_VARIANT := v2 (8M)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e600g-v2-8m
+
+define Device/qxwlan_e600gac-v2
+ SOC := qca9531
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E600GAC
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
+ SUPPORTED_DEVICES += e600gac-v2
+endef
+
+define Device/qxwlan_e600gac-v2-16m
+ $(Device/qxwlan_e600gac-v2)
+ DEVICE_VARIANT := v2 (16M)
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e600gac-v2-16m
+
+define Device/qxwlan_e600gac-v2-8m
+ $(Device/qxwlan_e600gac-v2)
+ DEVICE_VARIANT := v2 (8M)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e600gac-v2-8m
+
define Device/qxwlan_e750a-v4
SOC := ar9344
DEVICE_VENDOR := Qxwlan