aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 3e32a08295..b3b510a2ec 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1308,6 +1308,18 @@ define Device/engenius_ews511ap
endef
TARGET_DEVICES += engenius_ews511ap
+define Device/engenius_ews660ap
+ $(Device/senao_loader_okli)
+ SOC := qca9558
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := EWS660AP
+ DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
+ IMAGE_SIZE := 11584k
+ LOADER_FLASH_OFFS := 0x220000
+ SENAO_IMGNAME := ar71xx-generic-ews660ap
+endef
+TARGET_DEVICES += engenius_ews660ap
+
define Device/enterasys_ws-ap3705i
SOC := ar9344
DEVICE_VENDOR := Enterasys