aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 900c9dbf3c..d088f91019 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2509,6 +2509,22 @@ define Device/teltonika_rut955-h7v3c0
endef
TARGET_DEVICES += teltonika_rut955-h7v3c0
+define Device/trendnet_tew-673gru
+ SOC := ar7161
+ DEVICE_VENDOR := Trendnet
+ DEVICE_MODEL := TEW-673GRU
+ DEVICE_VARIANT := v1.0R
+ DEVICE_PACKAGES := -uboot-envtools kmod-usb-ohci kmod-usb2 \
+ kmod-owl-loader kmod-switch-rtl8366s
+ IMAGE_SIZE := 7808k
+ FACTORY_SIZE := 6144k
+ IMAGES += factory.bin
+ IMAGE/factory.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+ pad-rootfs | check-size $$$$(FACTORY_SIZE) | pad-to $$$$(FACTORY_SIZE) | \
+ append-string AP94-AR7161-RT-080619-01
+endef
+TARGET_DEVICES += trendnet_tew-673gru
+
define Device/trendnet_tew-823dru
SOC := qca9558
DEVICE_VENDOR := Trendnet