aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk25
1 files changed, 17 insertions, 8 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index c4b810cb59..2b81690654 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1454,15 +1454,24 @@ define Device/jjplus_ja76pf2
DEVICE_VENDOR := jjPlus
DEVICE_MODEL := JA76PF2
DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-basic-wolfssl -uboot-envtools fconfig
- IMAGES += kernel.bin rootfs.bin
- IMAGE/kernel.bin := append-kernel
- IMAGE/rootfs.bin := append-rootfs | pad-rootfs
- IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | \
- check-size | append-metadata
- KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
+ LOADER_TYPE := bin
+ LOADER_FLASH_OFFS := 0x60000
+ COMPILE := loader-$(1).bin
+ COMPILE/loader-$(1).bin := loader-okli-compile | lzma | pad-to 128k
+ ARTIFACTS := loader.bin
+ ARTIFACT/loader.bin := append-loader-okli $(1)
+ IMAGES += firmware.bin
+ IMAGE/firmware.bin := append-kernel | uImage lzma -M 0x4f4b4c49 | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | check-size
+ IMAGE/sysupgrade.bin := $$(IMAGE/firmware.bin) | \
+ sysupgrade-tar kernel=$$$$(KDIR)/loader-$(1).bin rootfs=$$$$@ | append-metadata
+ KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb
- IMAGE_SIZE := 16000k
- SUPPORTED_DEVICES += ja76pf2
+ IMAGE_SIZE := 15872k
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := Partition design has changed compared to older versions (19.07 and 21.02) \
+ due to kernel drivers restrictions. Upgrade via sysupgrade mechanism is one way operation. \
+ Downgrading OpenWrt version will involve usage of bootloader command line interface.
endef
TARGET_DEVICES += jjplus_ja76pf2