aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 71dc261b2c..528a63f629 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1475,6 +1475,27 @@ define Device/qihoo_c301
endef
TARGET_DEVICES += qihoo_c301
+define Device/qxwlan_e558-v2
+ SOC := qca9558
+ DEVICE_VENDOR := Qxwlan
+ DEVICE_MODEL := E558
+ DEVICE_PACKAGES := kmod-usb2
+endef
+
+define Device/qxwlan_e558-v2-16m
+ $(Device/qxwlan_e558-v2)
+ DEVICE_VARIANT := v2 (16M)
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e558-v2-16m
+
+define Device/qxwlan_e558-v2-8m
+ $(Device/qxwlan_e558-v2)
+ DEVICE_VARIANT := v2 (8M)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e558-v2-8m
+
define Device/qxwlan_e750a-v4
SOC := ar9344
DEVICE_VENDOR := Qxwlan