aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 4327512e17..909c68befa 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1019,6 +1019,22 @@ define Device/librerouter_librerouter-v1
endef
TARGET_DEVICES += librerouter_librerouter-v1
+define Device/meraki_mr16
+ SOC := ar7161
+ DEVICE_VENDOR := Meraki
+ DEVICE_MODEL := MR16
+ IMAGE_SIZE := 15616k
+ DEVICE_PACKAGES := kmod-owl-loader
+ SUPPORTED_DEVICES += mr16
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := Partitions differ from ar71xx version of MR16. Image format is incompatible. \
+ To use sysupgrade, you must change /lib/update/common.sh::get_image to prepend 128K zeroes to this image, \
+ and change the bootcmd in u-boot to "bootm 0xbf0a0000". After that, you can use "sysupgrade -F". \
+ For more details, see the OpenWrt Wiki: https://openwrt.org/toh/meraki/mr16, \
+ or the commit message of the MR16 ath79 port on git.openwrt.org.
+endef
+TARGET_DEVICES += meraki_mr16
+
define Device/nec_wg1200cr
SOC := qca9563
DEVICE_VENDOR := NEC