aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 769c0ee1da..33a72358b3 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2528,6 +2528,17 @@ define Device/yuncore_a782
endef
TARGET_DEVICES += yuncore_a782
+define Device/yuncore_xd3200
+ SOC := qca9563
+ DEVICE_VENDOR := YunCore
+ DEVICE_MODEL := XD3200
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 16000k
+ IMAGES += tftp.bin
+ IMAGE/tftp.bin := $$(IMAGE/sysupgrade.bin) | yuncore-tftp-header-16m
+endef
+TARGET_DEVICES += yuncore_xd3200
+
define Device/yuncore_xd4200
SOC := qca9563
DEVICE_VENDOR := YunCore