aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index b170323394..fb393ba082 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1414,6 +1414,21 @@ define Device/joyit_jt-or750i
endef
TARGET_DEVICES += joyit_jt-or750i
+define Device/letv_lba-047-ch
+ $(Device/loader-okli-uimage)
+ SOC := qca9531
+ DEVICE_VENDOR := Letv
+ DEVICE_MODEL := LBA-047-CH
+ IMAGE_SIZE := 15936k
+ LOADER_FLASH_OFFS := 0x50000
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | pad-to 14528k | \
+ append-loader-okli-uimage $(1) | pad-to 64k
+endef
+TARGET_DEVICES += letv_lba-047-ch
+
define Device/librerouter_librerouter-v1
SOC := qca9558
DEVICE_VENDOR := Librerouter