aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 6b7bfb4639..ee798bf321 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1367,6 +1367,17 @@ define Device/sitecom_wlr-8100
endef
TARGET_DEVICES += sitecom_wlr-8100
+define Device/telco_t1
+ SOC := qca9531
+ DEVICE_VENDOR := Telco
+ DEVICE_MODEL := T1
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-net-qmi-wwan \
+ kmod-usb-serial-option uqmi -swconfig -uboot-envtools
+ IMAGE_SIZE := 16192k
+ SUPPORTED_DEVICES += telco_electronics,tel-t1
+endef
+TARGET_DEVICES += telco_t1
+
define Device/teltonika_rut955
SOC := ar9344
DEVICE_VENDOR := Teltonika