aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index acb456ba44..ded8e29c2c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1630,6 +1630,25 @@ define Device/openmesh_om2p-lc
endef
TARGET_DEVICES += openmesh_om2p-lc
+define Device/openmesh_om5p-common
+ SOC := ar9344
+ DEVICE_VENDOR := OpenMesh
+ DEVICE_PACKAGES := uboot-envtools
+ IMAGE_SIZE := 7808k
+ BLOCKSIZE := 64k
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | \
+ pad-to $$(BLOCKSIZE)
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
+ openmesh-image ce_type=OM5P | append-metadata
+endef
+
+define Device/openmesh_om5p
+ $(Device/openmesh_om5p-common)
+ DEVICE_MODEL := OM5P
+ SUPPORTED_DEVICES += om5p
+endef
+TARGET_DEVICES += openmesh_om5p
+
define Device/openmesh_om5p-ac-v2
SOC := qca9558
DEVICE_VENDOR := OpenMesh