aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index d8cac425e8..14e72140dc 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -50,6 +50,17 @@ define Build/cybertan-trx
-rm $@-empty.bin
endef
+define Build/mkdapimg2
+ $(STAGING_DIR_HOST)/bin/mkdapimg2 \
+ -i $@ -o $@.new \
+ -s $(DAP_SIGNATURE) \
+ -v $(VERSION_DIST)-$(firstword $(subst +, , \
+ $(firstword $(subst -, ,$(REVISION))))) \
+ -r Default \
+ $(if $(1),-k $(1))
+ mv $@.new $@
+endef
+
define Build/mkmylofw_16m
$(eval device_id=$(word 1,$(1)))
$(eval revision=$(word 2,$(1)))
@@ -563,6 +574,20 @@ define Device/dlink_dap-2695-a1
endef
TARGET_DEVICES += dlink_dap-2695-a1
+define Device/dlink_dch-g020-a1
+ SOC := qca9531
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DCH-G020
+ DEVICE_VARIANT := A1
+ DEVICE_PACKAGES := kmod-gpio-pca953x kmod-i2c-gpio kmod-usb2 kmod-usb-acm
+ IMAGES += factory.bin
+ IMAGE_SIZE := 14784k
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | mkdapimg2 0x20000
+ DAP_SIGNATURE := HONEYBEE-FIRMWARE-DCH-G020
+endef
+TARGET_DEVICES += dlink_dch-g020-a1
+
define Device/dlink_dir-505
SOC := ar9330
DEVICE_VENDOR := D-Link