aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 6e3dcf0bd8..16212826d8 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -313,13 +313,23 @@ define Device/glinet_gl-ar150
endef
TARGET_DEVICES += glinet_gl-ar150
-define Device/glinet_gl-ar300m-nor
+define Device/glinet_gl-ar300m-common-nor
ATH_SOC := qca9531
- DEVICE_TITLE := GL.iNet GL-AR300M
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
IMAGE_SIZE := 16000k
SUPPORTED_DEVICES += gl-ar300m
endef
+
+define Device/glinet_gl-ar300m-lite
+ $(Device/glinet_gl-ar300m-common-nor)
+ DEVICE_TITLE := GL.iNet GL-AR300M-Lite
+endef
+TARGET_DEVICES += glinet_gl-ar300m-lite
+
+define Device/glinet_gl-ar300m-nor
+ $(Device/glinet_gl-ar300m-common-nor)
+ DEVICE_TITLE := GL.iNet GL-AR300M
+endef
TARGET_DEVICES += glinet_gl-ar300m-nor
define Device/glinet_gl-ar750s