aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 86afa11deb..91cd5fc681 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -84,6 +84,16 @@ define Device/ubnt_nano-m
endef
TARGET_DEVICES += ubnt_nano-m
+define Device/ubnt_nanostation-ac
+ $(Device/ubnt-wa)
+ DEVICE_TITLE := Ubiquiti Nanostation AC
+ DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+ IMAGE_SIZE := 15744k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+endef
+TARGET_DEVICES += ubnt_nanostation-ac
+
define Device/ubnt_nanostation-ac-loco
$(Device/ubnt-wa)
DEVICE_TITLE := Ubiquiti Nanostation AC loco