aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk54
1 files changed, 26 insertions, 28 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 537dafa152..49b28f7599 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -1,19 +1,18 @@
include ./common-tp-link.mk
-define Device/tl-archer-c7-v2
+define Device/tplink_tl-archer-c7-v2
$(Device/tplink-16mlzma)
ATH_SOC := qca9558
DEVICE_TITLE := TP-LINK Archer C7 v2
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca988x
TPLINK_HWID := 0xc7000002
- SUPPORTED_DEVICES := tplink,tl-archer-c7-v2
IMAGES := sysupgrade.bin factory.bin factory-us.bin factory-eu.bin
IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
endef
-TARGET_DEVICES += tl-archer-c7-v2
+TARGET_DEVICES += tplink_tl-archer-c7-v2
-define Device/tl-re450-v2
+define Device/tplink_tl-re450-v2
$(Device/tplink)
ATH_SOC := qca9563
IMAGE_SIZE := 6016k
@@ -27,59 +26,58 @@ define Device/tl-re450-v2
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
- SUPPORTED_DEVICES := tplink,re450-v2
endef
-TARGET_DEVICES += tl-re450-v2
+TARGET_DEVICES += tplink_tl-re450-v2
-define Device/tl-wdr3600
+define Device/tplink_tl-wdr3600
$(Device/tplink-8mlzma)
ATH_SOC := ar9344
DEVICE_TITLE := TP-LINK TL-WDR3600
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x36000001
- SUPPORTED_DEVICES := tplink,tl-wdr3600 tl-wdr3600
+ SUPPORTED_DEVICES += tl-wdr3600
endef
-TARGET_DEVICES += tl-wdr3600
+TARGET_DEVICES += tplink_tl-wdr3600
-define Device/tl-wdr4300
- $(Device/tl-wdr3600)
+define Device/tplink_tl-wdr4300
+ $(Device/tplink_tl-wdr3600)
DEVICE_TITLE := TP-LINK TL-WDR4300
TPLINK_HWID := 0x43000001
- SUPPORTED_DEVICES := tplink,tl-wdr4300 tl-wdr4300
+ SUPPORTED_DEVICES += tl-wdr4300
endef
-TARGET_DEVICES += tl-wdr4300
+TARGET_DEVICES += tplink_tl-wdr4300
-define Device/tl-wr1043nd-v1
+define Device/tplink_tl-wr1043nd-v1
$(Device/tplink-8m)
ATH_SOC := ar9132
DEVICE_TITLE := TP-LINK TL-WR1043N/ND v1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x10430001
- SUPPORTED_DEVICES := tplink,tl-wr1043nd-v1 tl-wr1043nd
+ SUPPORTED_DEVICES += tl-wr1043nd
endef
-TARGET_DEVICES += tl-wr1043nd-v1
+TARGET_DEVICES += tplink_tl-wr1043nd-v1
-define Device/tl-wr1043nd-v2
+define Device/tplink_tl-wr1043nd-v2
$(Device/tplink-8mlzma)
ATH_SOC := qca9558
DEVICE_TITLE := TP-LINK TL-WR1043N/ND v2
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x10430002
- SUPPORTED_DEVICES := tplink,tl-wr1043nd-v2 tl-wr1043nd-v2
+ SUPPORTED_DEVICES += tl-wr1043nd-v2
endef
-TARGET_DEVICES += tl-wr1043nd-v2
+TARGET_DEVICES += tplink_tl-wr1043nd-v2
-define Device/tl-wr1043nd-v3
+define Device/tplink_tl-wr1043nd-v3
$(Device/tplink-8mlzma)
ATH_SOC := qca9558
DEVICE_TITLE := TP-LINK TL-WR1043N/ND v3
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x10430003
- SUPPORTED_DEVICES := tplink,tl-wr1043nd-v3 tl-wr1043nd-v3
+ SUPPORTED_DEVICES += tl-wr1043nd-v3
endef
-TARGET_DEVICES += tl-wr1043nd-v3
+TARGET_DEVICES += tplink_tl-wr1043nd-v3
-define Device/tl-wr1043nd-v4
+define Device/tplink_tl-wr1043nd-v4
$(Device/tplink)
ATH_SOC := qca9563
IMAGE_SIZE := 15552k
@@ -91,11 +89,11 @@ define Device/tl-wr1043nd-v4
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
- SUPPORTED_DEVICES := tplink,tl-wr1043nd-v4 tl-wr1043nd-v4
+ SUPPORTED_DEVICES += tl-wr1043nd-v4
endef
-TARGET_DEVICES += tl-wr1043nd-v4
+TARGET_DEVICES += tplink_tl-wr1043nd-v4
-define Device/tl-wr2543-v1
+define Device/tplink_tl-wr2543-v1
$(Device/tplink-8mlzma)
ATH_SOC := ar7242
DEVICE_TITLE := TP-LINK TL-WR2543N/ND v1
@@ -104,6 +102,6 @@ define Device/tl-wr2543-v1
IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade -v 3.13.99 | \
append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := append-rootfs | mktplinkfw factory -v 3.13.99
- SUPPORTED_DEVICES := tplink,tl-wr2543-v1 tl-wr2543-v1
+ SUPPORTED_DEVICES += tl-wr2543-v1
endef
-TARGET_DEVICES += tl-wr2543-v1
+TARGET_DEVICES += tplink_tl-wr2543-v1