aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-buffalo.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/common-buffalo.mk')
-rw-r--r--target/linux/ath79/image/common-buffalo.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-buffalo.mk b/target/linux/ath79/image/common-buffalo.mk
new file mode 100644
index 0000000000..a756f8448b
--- /dev/null
+++ b/target/linux/ath79/image/common-buffalo.mk
@@ -0,0 +1,20 @@
+define Build/buffalo-tftp-header
+ ( \
+ echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+endef
+
+define Build/buffalo-tag
+ $(eval product=$(word 1,$(1)))
+ $(STAGING_DIR_HOST)/bin/buffalo-tag \
+ -c 0x80041000 -d 0x801e8000 -w 3 \
+ -a ath -v 1.99 -m 1.01 -f 1 \
+ -b $(product) -p $(product) \
+ -r M_ -l mlang8 \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
+