aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index aee4ddf963..38c623bf27 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -84,6 +84,14 @@ define Device/Default
append-rootfs | pad-rootfs | check-size | append-metadata
endef
+define Device/loader-okli-uimage
+ LOADER_TYPE := bin
+ COMPILE := loader-$(1).bin loader-$(1).uImage
+ COMPILE/loader-$(1).bin := loader-okli-compile
+ COMPILE/loader-$(1).uImage := append-loader-okli $(1) | pad-to 64k | \
+ lzma | uImage lzma
+endef
+
include $(SUBTARGET).mk
ifeq ($(SUBTARGET),generic)