aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches-5.10/190-media-atmel-fix-build-when-ISC-m-and-XISC-y.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/patches-5.10/190-media-atmel-fix-build-when-ISC-m-and-XISC-y.patch')
-rw-r--r--target/linux/at91/patches-5.10/190-media-atmel-fix-build-when-ISC-m-and-XISC-y.patch21
1 files changed, 6 insertions, 15 deletions
diff --git a/target/linux/at91/patches-5.10/190-media-atmel-fix-build-when-ISC-m-and-XISC-y.patch b/target/linux/at91/patches-5.10/190-media-atmel-fix-build-when-ISC-m-and-XISC-y.patch
index f4d7bacdb4..60b4104442 100644
--- a/target/linux/at91/patches-5.10/190-media-atmel-fix-build-when-ISC-m-and-XISC-y.patch
+++ b/target/linux/at91/patches-5.10/190-media-atmel-fix-build-when-ISC-m-and-XISC-y.patch
@@ -32,8 +32,6 @@ Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
drivers/media/platform/atmel/atmel-isc-base.c | 11 +++++++++++
3 files changed, 22 insertions(+), 2 deletions(-)
-diff --git a/drivers/media/platform/atmel/Kconfig b/drivers/media/platform/atmel/Kconfig
-index 99b51213f871..dda2f27da317 100644
--- a/drivers/media/platform/atmel/Kconfig
+++ b/drivers/media/platform/atmel/Kconfig
@@ -8,6 +8,7 @@ config VIDEO_ATMEL_ISC
@@ -62,8 +60,6 @@ index 99b51213f871..dda2f27da317 100644
config VIDEO_ATMEL_ISI
tristate "ATMEL Image Sensor Interface (ISI) support"
depends on VIDEO_V4L2 && OF
-diff --git a/drivers/media/platform/atmel/Makefile b/drivers/media/platform/atmel/Makefile
-index c5c01556c653..46d264ab7948 100644
--- a/drivers/media/platform/atmel/Makefile
+++ b/drivers/media/platform/atmel/Makefile
@@ -1,7 +1,8 @@
@@ -77,8 +73,6 @@ index c5c01556c653..46d264ab7948 100644
+obj-$(CONFIG_VIDEO_ATMEL_ISC_BASE) += atmel-isc-base.o
obj-$(CONFIG_VIDEO_ATMEL_ISC) += atmel-isc.o
obj-$(CONFIG_VIDEO_ATMEL_XISC) += atmel-xisc.o
-diff --git a/drivers/media/platform/atmel/atmel-isc-base.c b/drivers/media/platform/atmel/atmel-isc-base.c
-index 46c6e3e20f33..54168b72fd2f 100644
--- a/drivers/media/platform/atmel/atmel-isc-base.c
+++ b/drivers/media/platform/atmel/atmel-isc-base.c
@@ -378,6 +378,7 @@ int isc_clk_init(struct isc_device *isc)
@@ -89,7 +83,7 @@ index 46c6e3e20f33..54168b72fd2f 100644
void isc_clk_cleanup(struct isc_device *isc)
{
-@@ -392,6 +393,7 @@ void isc_clk_cleanup(struct isc_device *isc)
+@@ -392,6 +393,7 @@ void isc_clk_cleanup(struct isc_device *
clk_unregister(isc_clk->clk);
}
}
@@ -97,7 +91,7 @@ index 46c6e3e20f33..54168b72fd2f 100644
static int isc_queue_setup(struct vb2_queue *vq,
unsigned int *nbuffers, unsigned int *nplanes,
-@@ -1575,6 +1577,7 @@ irqreturn_t isc_interrupt(int irq, void *dev_id)
+@@ -1575,6 +1577,7 @@ irqreturn_t isc_interrupt(int irq, void
return ret;
}
@@ -105,7 +99,7 @@ index 46c6e3e20f33..54168b72fd2f 100644
static void isc_hist_count(struct isc_device *isc, u32 *min, u32 *max)
{
-@@ -2209,6 +2212,7 @@ const struct v4l2_async_notifier_operations isc_async_ops = {
+@@ -2209,6 +2212,7 @@ const struct v4l2_async_notifier_operati
.unbind = isc_async_unbind,
.complete = isc_async_complete,
};
@@ -113,7 +107,7 @@ index 46c6e3e20f33..54168b72fd2f 100644
void isc_subdev_cleanup(struct isc_device *isc)
{
-@@ -2221,6 +2225,7 @@ void isc_subdev_cleanup(struct isc_device *isc)
+@@ -2221,6 +2225,7 @@ void isc_subdev_cleanup(struct isc_devic
INIT_LIST_HEAD(&isc->subdev_entities);
}
@@ -121,7 +115,7 @@ index 46c6e3e20f33..54168b72fd2f 100644
int isc_pipeline_init(struct isc_device *isc)
{
-@@ -2261,6 +2266,7 @@ int isc_pipeline_init(struct isc_device *isc)
+@@ -2261,6 +2266,7 @@ int isc_pipeline_init(struct isc_device
return 0;
}
@@ -129,7 +123,7 @@ index 46c6e3e20f33..54168b72fd2f 100644
/* regmap configuration */
#define ATMEL_ISC_REG_MAX 0xd5c
-@@ -2270,4 +2276,9 @@ const struct regmap_config isc_regmap_config = {
+@@ -2270,4 +2276,9 @@ const struct regmap_config isc_regmap_co
.val_bits = 32,
.max_register = ATMEL_ISC_REG_MAX,
};
@@ -139,6 +133,3 @@ index 46c6e3e20f33..54168b72fd2f 100644
+MODULE_AUTHOR("Eugen Hristev");
+MODULE_DESCRIPTION("Atmel ISC common code base");
+MODULE_LICENSE("GPL v2");
---
-2.32.0
-