aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image')
-rw-r--r--target/linux/at91/image/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index e4c17e3a3c..3a906a6ca8 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -55,9 +55,13 @@ define Build/at91-sdcard
$(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin
- mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
- ::BOOT.bin
+ $(if $(findstring at91-sama5d27_som1_ek,$@), \
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+ ::BOOT.bin,
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+ ::BOOT.bin)
./gen_at91_sdcard_img.sh \
$@.img \