aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5d2.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image/sama5d2.mk')
-rw-r--r--target/linux/at91/image/sama5d2.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/at91/image/sama5d2.mk b/target/linux/at91/image/sama5d2.mk
new file mode 100644
index 0000000000..28a6f93aad
--- /dev/null
+++ b/target/linux/at91/image/sama5d2.mk
@@ -0,0 +1,23 @@
+
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d2_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d2_xplained
+
+define Device/at91-sama5d27_som1_ek
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d27_som1_ek