aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image/sama5.mk')
-rw-r--r--target/linux/at91/image/sama5.mk101
1 files changed, 0 insertions, 101 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
deleted file mode 100644
index fd7a53421e..0000000000
--- a/target/linux/at91/image/sama5.mk
+++ /dev/null
@@ -1,101 +0,0 @@
-AT91_SD_BOOT_PARTSIZE:=64
-FAT32_BLOCK_SIZE:=1024
-FAT32_BLOCKS:=$(shell echo \
- $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
-
-define Build/at91-sdcard
- $(if $(findstring ext4,$@), \
- rm -f $@.boot
- mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-
- mcopy -i $@.boot $(KDIR)/zImage ::zImage
-
- $(foreach dts,$(DEVICE_DTS), \
- mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
- ::$(dts).dtb)
-
- mcopy -i $@.boot \
- $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
- ::u-boot.bin
-
- mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
- ::BOOT.bin
-
- ./gen_at91_sdcard_img.sh \
- $@.img \
- $@.boot \
- $(KDIR)/root.ext4 \
- $(AT91_SD_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE)
-
- gzip -nc9 $@.img > $@
-
- rm -f $@.img $@.boot )
-endef
-
-define Device/evaluation-sdimage
- IMAGES += sdcard.img.gz
- IMAGE/sdcard.img.gz := at91-sdcard
-endef
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d3_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d3_xplained
-
-define Device/at91-sama5d2_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_xplained
-
-define Device/at91-sama5d4_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
- KERNEL_SIZE := 6144k
- BLOCKSIZE := 256k
- PAGESIZE := 4096
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d4_xplained
-
-define Device/at91-sama5d27_som1_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d27_som1_ek
-
-ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
- ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
- define Device/wb50n
- $(Device/evaluation-fit)
- DEVICE_TITLE := Laird WB50N
- DEVICE_PACKAGES := \
- kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
- kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
- kmod-leds-gpio
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
- endef
- TARGET_DEVICES += wb50n
- endif
-endif