aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image/Makefile')
-rw-r--r--target/linux/at91/image/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 959b1cb0a3..05f0b58af7 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR := 0x20008000
define Build/at91-install-zImage
- $(CP) $(KDIR)/zImage $@
+ $(CP) $(KDIR)/zImage $@
endef
include $(SUBTARGET).mk
@@ -24,7 +24,8 @@ define Device/Default
$(Device/default-nand)
PROFILES := Default
FILESYSTEMS := squashfs ubifs ext4
- DEVICE_DTS := $(1)
+ DEVICE_DTS = $(lastword $(subst _, ,$(1)))
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
KERNEL_NAME := zImage
KERNEL_SIZE := 4096k
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
@@ -56,13 +57,13 @@ define Device/evaluation-dtb
$(Device/evaluation)
$(Device/dtb)
KERNEL_SUFFIX := -fit-zImage.itb
- KERNEL := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
endef
define Device/evaluation-fit
$(Device/evaluation)
KERNEL_SUFFIX := -fit-uImage.itb
- KERNEL := kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
+ KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(DEVICE_DTS).dtb
endef
define Device/production
@@ -74,8 +75,8 @@ endef
define Device/production-dtb
$(Device/production)
$(Device/dtb)
- IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
- | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) | \
+ append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
$(eval $(call BuildImage))