aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image/Makefile')
-rw-r--r--target/linux/at91/image/Makefile51
1 files changed, 49 insertions, 2 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 93180dd64f..49d93aa97d 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -16,10 +16,21 @@ endef
ifeq ($(SUBTARGET),legacy)
include ./legacy.mk
endif
-ifeq ($(SUBTARGET),sama5)
-include ./sama5.mk
+ifeq ($(SUBTARGET),sama5d2)
+include ./sama5d2.mk
+endif
+ifeq ($(SUBTARGET),sama5d3)
+include ./sama5d3.mk
+endif
+ifeq ($(SUBTARGET),sama5d4)
+include ./sama5d4.mk
endif
+AT91_SD_BOOT_PARTSIZE:=64
+FAT32_BLOCK_SIZE:=1024
+FAT32_BLOCKS:=$(shell echo \
+ $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+
define Device/Default
$(Device/default-nand)
PROFILES := Default
@@ -35,6 +46,42 @@ define Device/dtb
KERNEL := kernel-bin | lzma | uImage lzma
endef
+define Build/at91-sdcard
+ $(if $(findstring ext4,$@), \
+ rm -f $@.boot
+ mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+
+ mcopy -i $@.boot $(KDIR)/zImage ::zImage
+
+ $(foreach dts,$(DEVICE_DTS), \
+ mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
+ ::$(dts).dtb)
+
+ mcopy -i $@.boot \
+ $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+ ::u-boot.bin
+
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd*/at91bootstrap.bin \
+ ::BOOT.bin
+
+ ./gen_at91_sdcard_img.sh \
+ $@.img \
+ $@.boot \
+ $(KDIR)/root.ext4 \
+ $(AT91_SD_BOOT_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+
+ gzip -nc9 $@.img > $@
+
+ rm -f $@.img $@.boot )
+endef
+
+define Device/evaluation-sdimage
+ IMAGES += sdcard.img.gz
+ IMAGE/sdcard.img.gz := at91-sdcard
+endef
+
define Device/evaluation
KERNEL_INSTALL := 1
KERNEL_SUFFIX := -uImage