aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/armsr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/armsr/Makefile')
-rw-r--r--target/linux/armsr/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/armsr/Makefile b/target/linux/armsr/Makefile
new file mode 100644
index 0000000000..755c77f446
--- /dev/null
+++ b/target/linux/armsr/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
+
+include $(TOPDIR)/rules.mk
+
+BOARD:=armsr
+BOARDNAME:=Arm SystemReady (EFI) compliant
+FEATURES:=fpu pci pcie rtc usb boot-part rootfs-part
+FEATURES+=cpiogz ext4 ramdisk squashfs targz vmdk
+
+KERNEL_PATCHVER:=5.15
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+# blkid used for resolving PARTUUID
+# in sysupgrade
+DEFAULT_PACKAGES += blkid
+
+$(eval $(call BuildTarget))