aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds21
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh4
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh6
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ar71xx/config-4.42
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt19
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile2
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-r602n.c213
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h2
-rw-r--r--target/linux/ar71xx/image/generic.mk17
-rw-r--r--target/linux/ar71xx/mikrotik/config-default2
-rw-r--r--target/linux/ar71xx/nand/config-default2
13 files changed, 285 insertions, 8 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 082b6c478e..1a4b02c535 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -83,6 +83,7 @@ ap147-010)
ucidef_set_led_wlan "wlan2g" "WLAN 2.4 GHz" "ap147:green:wlan-2g" "phy0tpt"
;;
ap90q|\
+cpe505n|\
cpe830|\
cpe870|\
dr531)
@@ -93,6 +94,9 @@ dr531)
ap90q)
ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
;;
+ cpe505n)
+ ucidef_set_led_wlan "wlan" "WLAN" "$board:blue:wlan" "phy0tpt"
+ ;;
cpe830|\
cpe870)
ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
@@ -502,6 +506,15 @@ pqi-air-pen)
qihoo-c301)
ucidef_set_led_wlan "wlan2g" "WLAN2G" "qihoo:red:status" "phy1tpt"
;;
+r602n|\
+zbt-we1526)
+ ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
+ ucidef_set_led_switch "lan1" "LAN1" "$board:green:lan1" "switch0" "0x10"
+ ucidef_set_led_switch "lan2" "LAN2" "$board:green:lan2" "switch0" "0x08"
+ ucidef_set_led_switch "lan3" "LAN3" "$board:green:lan3" "switch0" "0x04"
+ ucidef_set_led_switch "lan4" "LAN4" "$board:green:lan4" "switch0" "0x02"
+ ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
+ ;;
re450)
ucidef_set_led_netdev "lan_data" "LAN Data" "$board:green:lan_data" "eth0" "tx rx"
ucidef_set_led_netdev "lan_link" "LAN Link" "$board:green:lan_link" "eth0" "link"
@@ -846,14 +859,6 @@ xd3200)
z1)
ucidef_set_led_netdev "wlan1" "WLAN1" "$board:blue:tricolor0" "wlan1"
;;
-zbt-we1526)
- ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
- ucidef_set_led_switch "lan1" "LAN1" "$board:green:lan1" "switch0" "0x10"
- ucidef_set_led_switch "lan2" "LAN2" "$board:green:lan2" "switch0" "0x08"
- ucidef_set_led_switch "lan3" "LAN3" "$board:green:lan3" "switch0" "0x04"
- ucidef_set_led_switch "lan4" "LAN4" "$board:green:lan4" "switch0" "0x02"
- ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
- ;;
zcn-1523h-2)
ucidef_set_led_netdev "lan1" "lan1" "zcn-1523h:green:lan1" "eth0"
;;
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index 08ee584480..e5892ac485 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -31,6 +31,7 @@ ar71xx_setup_interfaces()
mynet-n600|\
oolite|\
qihoo-c301|\
+ r602n|\
rb-750|\
rb-751|\
som9331|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 00f6a7db07..fed51a17d7 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -32,6 +32,7 @@ get_status_led() {
;;
ap132|\
ap531b0|\
+ cpe505n|\
db120|\
dr344|\
tew-632brp|\
@@ -280,6 +281,9 @@ get_status_led() {
pb44)
status_led="$board:amber:jump1"
;;
+ r602n)
+ status_led="$board:green:wan"
+ ;;
rb-2011l|\
rb-2011uas|\
rb-2011uas-2hnd)
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 267cb6ad58..eedcb7829c 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -508,6 +508,9 @@ ar71xx_board_detect() {
name="cpe210"
tplink_pharos_board_detect
;;
+ *"CPE505N")
+ name="cpe505n"
+ ;;
*"CPE510/520")
name="cpe510"
tplink_pharos_board_detect
@@ -802,6 +805,9 @@ ar71xx_board_detect() {
*"Qihoo 360 C301")
name="qihoo-c301"
;;
+ *"R602N")
+ name="r602n"
+ ;;
*"R6100")
name="r6100"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 38a78830a0..2f0228b823 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -217,6 +217,7 @@ platform_check_image() {
cf-e380ac-v2|\
cf-e520n|\
cf-e530n|\
+ cpe505n|\
cpe830|\
cpe870|\
dgl-5500-a1|\
@@ -256,6 +257,7 @@ platform_check_image() {
nanostation-m|\
nbg460n_550n_550nh|\
pqi-air-pen|\
+ r602n|\
rocket-m-ti|\
rocket-m-xw|\
rocket-m|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index 09ffd8b6bf..386ce6824e 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -70,6 +70,7 @@ CONFIG_ATH79_MACH_CF_E380AC_V1=y
CONFIG_ATH79_MACH_CF_E380AC_V2=y
CONFIG_ATH79_MACH_CF_E520N=y
CONFIG_ATH79_MACH_CF_E530N=y
+CONFIG_ATH79_MACH_CPE505N=y
CONFIG_ATH79_MACH_CPE510=y
CONFIG_ATH79_MACH_CPE830=y
CONFIG_ATH79_MACH_CPE870=y
@@ -143,6 +144,7 @@ CONFIG_ATH79_MACH_PB42=y
CONFIG_ATH79_MACH_PB44=y
CONFIG_ATH79_MACH_PQI_AIR_PEN=y
CONFIG_ATH79_MACH_QIHOO_C301=y
+CONFIG_ATH79_MACH_R602N=y
CONFIG_ATH79_MACH_R6100=y
# CONFIG_ATH79_MACH_RB2011 is not set
# CONFIG_ATH79_MACH_RB4XX is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index d72c462f6e..669e02684f 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -851,6 +851,16 @@ config ATH79_MACH_WRTNODE2Q
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_R602N
+ bool "P&W R602N support"
+ select SOC_QCA953X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_R6100
bool "NETGEAR R6100 board support"
select SOC_AR934X
@@ -1308,6 +1318,15 @@ config ATH79_MACH_ARCHER_C7
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_CPE505N
+ bool "P&W CPE505N support"
+ select SOC_QCA953X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_CPE510
bool "TP-LINK CPE510 support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 7e1a71b34d..1180d4d73b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -75,6 +75,7 @@ obj-$(CONFIG_ATH79_MACH_CF_E380AC_V1) += mach-cf-e316n-v2.o
obj-$(CONFIG_ATH79_MACH_CF_E380AC_V2) += mach-cf-e316n-v2.o
obj-$(CONFIG_ATH79_MACH_CF_E520N) += mach-cf-e316n-v2.o
obj-$(CONFIG_ATH79_MACH_CF_E530N) += mach-cf-e316n-v2.o
+obj-$(CONFIG_ATH79_MACH_CPE505N) += mach-r602n.o
obj-$(CONFIG_ATH79_MACH_CPE510) += mach-cpe510.o
obj-$(CONFIG_ATH79_MACH_CPE830) += mach-ap90q.o
obj-$(CONFIG_ATH79_MACH_CPE870) += mach-cpe870.o
@@ -147,6 +148,7 @@ obj-$(CONFIG_ATH79_MACH_PB42) += mach-pb42.o
obj-$(CONFIG_ATH79_MACH_PB44) += mach-pb44.o
obj-$(CONFIG_ATH79_MACH_PQI_AIR_PEN) += mach-pqi-air-pen.o
obj-$(CONFIG_ATH79_MACH_QIHOO_C301) += mach-qihoo-c301.o
+obj-$(CONFIG_ATH79_MACH_R602N) += mach-r602n.o
obj-$(CONFIG_ATH79_MACH_R6100) += mach-r6100.o
obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
obj-$(CONFIG_ATH79_MACH_RB4XX) += mach-rb4xx.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-r602n.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-r602n.c
new file mode 100644
index 0000000000..4aef0a932a
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-r602n.c
@@ -0,0 +1,213 @@
+/*
+ * P&W (Shenzhen Progress&Win Technologies) R602N and CPE505N boards support
+ *
+ * Copyright (C) 2017 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * Based on mach-zbt-we1526.c
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define PW_GPIO_BTN_RESET 17
+
+#define PW_KEYS_POLL_INTERVAL 20 /* msecs */
+#define PW_KEYS_DEBOUNCE_INTERVAL (3 * PW_KEYS_POLL_INTERVAL)
+
+#define PW_MAC0_OFFSET 0x0
+#define PW_MAC1_OFFSET 0x6
+#define PW_WMAC_CALDATA_OFFSET 0x1000
+
+/* CPE505N GPIO LEDs */
+#define CPE505N_GPIO_LED_DIAG 12
+#define CPE505N_GPIO_LED_LAN 11
+#define CPE505N_GPIO_LED_STATUS 14
+#define CPE505N_GPIO_LED_WAN 4
+#define CPE505N_GPIO_LED_WLAN 15
+
+static struct gpio_led cpe505n_leds_gpio[] __initdata = {
+ {
+ .name = "cpe505n:red:diag",
+ .gpio = CPE505N_GPIO_LED_DIAG,
+ .active_low = 1,
+ }, {
+ .name = "cpe505n:green:lan",
+ .gpio = CPE505N_GPIO_LED_LAN,
+ .active_low = 1,
+ }, {
+ .name = "cpe505n:green:status",
+ .gpio = CPE505N_GPIO_LED_STATUS,
+ .active_low = 1,
+ }, {
+ .name = "cpe505n:green:wan",
+ .gpio = CPE505N_GPIO_LED_WAN,
+ .active_low = 1,
+ }, {
+ .name = "cpe505n:blue:wlan",
+ .gpio = CPE505N_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+};
+
+static void __init cpe505n_gpio_setup(void)
+{
+ /* For LED on GPIO4 */
+ ath79_gpio_function_disable(AR934X_GPIO_FUNC_CLK_OBS4_EN);
+ ath79_gpio_output_select(CPE505N_GPIO_LED_WAN, 0);
+
+ ath79_gpio_direction_select(CPE505N_GPIO_LED_DIAG, true);
+ ath79_gpio_direction_select(CPE505N_GPIO_LED_LAN, true);
+ ath79_gpio_direction_select(CPE505N_GPIO_LED_STATUS, true);
+ ath79_gpio_direction_select(CPE505N_GPIO_LED_WAN, true);
+ ath79_gpio_direction_select(CPE505N_GPIO_LED_WLAN, true);
+
+ /* Mute LEDs */
+ gpio_set_value(CPE505N_GPIO_LED_DIAG, 1);
+ gpio_set_value(CPE505N_GPIO_LED_LAN, 1);
+ gpio_set_value(CPE505N_GPIO_LED_STATUS, 1);
+ gpio_set_value(CPE505N_GPIO_LED_WAN, 1);
+ gpio_set_value(CPE505N_GPIO_LED_WLAN, 1);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(cpe505n_leds_gpio),
+ cpe505n_leds_gpio);
+}
+
+/* R602N GPIO LEDs */
+#define R602N_GPIO_LED_LAN1 16
+#define R602N_GPIO_LED_LAN2 15
+#define R602N_GPIO_LED_LAN3 14
+#define R602N_GPIO_LED_LAN4 11
+#define R602N_GPIO_LED_WAN 4
+#define R602N_GPIO_LED_WLAN 12
+
+static struct gpio_led r602n_leds_gpio[] __initdata = {
+ {
+ .name = "r602n:green:lan1",
+ .gpio = R602N_GPIO_LED_LAN1,
+ .active_low = 1,
+ }, {
+ .name = "r602n:green:lan2",
+ .gpio = R602N_GPIO_LED_LAN2,
+ .active_low = 1,
+ }, {
+ .name = "r602n:green:lan3",
+ .gpio = R602N_GPIO_LED_LAN3,
+ .active_low = 1,
+ }, {
+ .name = "r602n:green:lan4",
+ .gpio = R602N_GPIO_LED_LAN4,
+ .active_low = 1,
+ }, {
+ .name = "r602n:green:wan",
+ .gpio = R602N_GPIO_LED_WAN,
+ .active_low = 1,
+ }, {
+ .name = "r602n:green:wlan",
+ .gpio = R602N_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+};
+
+static void __init r602n_gpio_setup(void)
+{
+ /* For LED on GPIO4 */
+ ath79_gpio_function_disable(AR934X_GPIO_FUNC_CLK_OBS4_EN);
+ ath79_gpio_output_select(R602N_GPIO_LED_WAN, 0);
+
+ ath79_gpio_direction_select(R602N_GPIO_LED_LAN1, true);
+ ath79_gpio_direction_select(R602N_GPIO_LED_LAN2, true);
+ ath79_gpio_direction_select(R602N_GPIO_LED_LAN3, true);
+ ath79_gpio_direction_select(R602N_GPIO_LED_LAN4, true);
+ ath79_gpio_direction_select(R602N_GPIO_LED_WAN, true);
+ ath79_gpio_direction_select(R602N_GPIO_LED_WLAN, true);
+
+ /* Mute LEDs */
+ gpio_set_value(R602N_GPIO_LED_LAN1, 1);
+ gpio_set_value(R602N_GPIO_LED_LAN2, 1);
+ gpio_set_value(R602N_GPIO_LED_LAN3, 1);
+ gpio_set_value(R602N_GPIO_LED_LAN4, 1);
+ gpio_set_value(R602N_GPIO_LED_WAN, 1);
+ gpio_set_value(R602N_GPIO_LED_WLAN, 1);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(r602n_leds_gpio),
+ r602n_leds_gpio);
+}
+
+static struct gpio_keys_button pw_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = PW_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = PW_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+};
+
+static void __init r602n_cpe505n_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_mdio(0, 0x0);
+
+ /* LAN */
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_switch_data.phy_poll_mask |= BIT(4);
+ ath79_init_mac(ath79_eth1_data.mac_addr, art + PW_MAC1_OFFSET, 0);
+ ath79_register_eth(1);
+
+ /* WAN */
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_init_mac(ath79_eth0_data.mac_addr, art + PW_MAC0_OFFSET, 0);
+ ath79_register_eth(0);
+
+ ath79_register_wmac(art + PW_WMAC_CALDATA_OFFSET, NULL);
+
+ ath79_register_gpio_keys_polled(-1, PW_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(pw_gpio_keys),
+ pw_gpio_keys);
+}
+
+static void __init cpe505n_setup(void)
+{
+ r602n_cpe505n_setup();
+
+ cpe505n_gpio_setup();
+}
+
+static void __init r602n_setup(void)
+{
+ r602n_cpe505n_setup();
+
+ r602n_gpio_setup();
+
+ ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_CPE505N, "CPE505N", "P&W CPE505N", cpe505n_setup);
+MIPS_MACHINE(ATH79_MACH_R602N, "R602N", "P&W R602N", r602n_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 27ebd47f29..b9cc243f39 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -62,6 +62,7 @@ enum ath79_mach_type {
ATH79_MACH_CF_E520N, /* COMFAST CF-E520N */
ATH79_MACH_CF_E530N, /* COMFAST CF-E530N */
ATH79_MACH_CPE210, /* TP-LINK CPE210 */
+ ATH79_MACH_CPE505N, /* P&W CPE505N */
ATH79_MACH_CPE510, /* TP-LINK CPE510 */
ATH79_MACH_CPE830, /* YunCore CPE830 */
ATH79_MACH_CPE870, /* YunCore CPE870 */
@@ -152,6 +153,7 @@ enum ath79_mach_type {
ATH79_MACH_PB44, /* Atheros PB44 reference board */
ATH79_MACH_PQI_AIR_PEN, /* PQI Air Pen */
ATH79_MACH_QIHOO_C301, /* Qihoo 360 C301 */
+ ATH79_MACH_R602N, /* P&W R602N */
ATH79_MACH_R6100, /* NETGEAR R6100 */
ATH79_MACH_RB_2011G, /* Mikrotik RouterBOARD 2011UAS-2HnD */
ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 34bb7da84d..37ffbe7ffa 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -85,6 +85,14 @@ define Device/cf-e530n
endef
TARGET_DEVICES += cf-e530n
+define Device/cpe505n
+ DEVICE_TITLE := P&W CPE505N
+ BOARDNAME = CPE505N
+ IMAGE_SIZE = 16000k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += cpe505n
+
define Device/cpe830
$(Device/ap90q)
DEVICE_TITLE := YunCore CPE830
@@ -426,6 +434,15 @@ define Device/jwap230
endef
TARGET_DEVICES += jwap230
+define Device/r602n
+ DEVICE_TITLE := P&W R602N
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME = R602N
+ IMAGE_SIZE = 16000k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += r602n
+
define Device/rnx-n360rt
$(Device/tplink-4m)
DEVICE_TITLE := Rosewill RNX-N360RT
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index 78a3fb340e..1cc485a7d1 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -35,6 +35,7 @@
# CONFIG_ATH79_MACH_CF_E380AC_V2 is not set
# CONFIG_ATH79_MACH_CF_E520N is not set
# CONFIG_ATH79_MACH_CF_E530N is not set
+# CONFIG_ATH79_MACH_CPE505N is not set
# CONFIG_ATH79_MACH_CPE510 is not set
# CONFIG_ATH79_MACH_CPE830 is not set
# CONFIG_ATH79_MACH_CPE870 is not set
@@ -108,6 +109,7 @@
# CONFIG_ATH79_MACH_PB44 is not set
# CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
# CONFIG_ATH79_MACH_QIHOO_C301 is not set
+# CONFIG_ATH79_MACH_R602N is not set
# CONFIG_ATH79_MACH_R6100 is not set
CONFIG_ATH79_MACH_RB2011=y
CONFIG_ATH79_MACH_RB4XX=y
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
index 8a9b61c057..16e652ed4e 100644
--- a/target/linux/ar71xx/nand/config-default
+++ b/target/linux/ar71xx/nand/config-default
@@ -34,6 +34,7 @@
# CONFIG_ATH79_MACH_CF_E380AC_V2 is not set
# CONFIG_ATH79_MACH_CF_E520N is not set
# CONFIG_ATH79_MACH_CF_E530N is not set
+# CONFIG_ATH79_MACH_CPE505N is not set
# CONFIG_ATH79_MACH_CPE510 is not set
# CONFIG_ATH79_MACH_CPE830 is not set
# CONFIG_ATH79_MACH_CPE870 is not set
@@ -104,6 +105,7 @@
# CONFIG_ATH79_MACH_PB44 is not set
# CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
# CONFIG_ATH79_MACH_QIHOO_C301 is not set
+# CONFIG_ATH79_MACH_R602N is not set
# CONFIG_ATH79_MACH_RE450 is not set
# CONFIG_ATH79_MACH_RW2458N is not set
# CONFIG_ATH79_MACH_SC1750 is not set