aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch')
-rw-r--r--target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch b/target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch
new file mode 100644
index 0000000000..da4e088471
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.4/471-ath79-tlt-rut900-flash-layout.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -202,6 +202,12 @@ config MTD_TPLINK_PARTS
+ ---help---
+ TBD.
+
++config MTD_TLT_PARTS
++ tristate "Teltonika RUT900 partitioning support"
++ depends on ATH79
++ ---help---
++ Teltonika RUT900 partitioning support
++
+ comment "User Modules And Translation Layers"
+
+ #
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47
+ obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+ obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
+ obj-$(CONFIG_MTD_CYBERTAN_PARTS) += cybertan_part.o
++obj-$(CONFIG_MTD_TLT_PARTS) += tltpart.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o