aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.2/420-net-ar71xx_mac_driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-3.2/420-net-ar71xx_mac_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.2/420-net-ar71xx_mac_driver.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.2/420-net-ar71xx_mac_driver.patch b/target/linux/ar71xx/patches-3.2/420-net-ar71xx_mac_driver.patch
new file mode 100644
index 0000000000..b65b3289a7
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.2/420-net-ar71xx_mac_driver.patch
@@ -0,0 +1,19 @@
+--- a/drivers/net/ethernet/atheros/Kconfig
++++ b/drivers/net/ethernet/atheros/Kconfig
+@@ -67,4 +67,6 @@ config ATL1C
+ To compile this driver as a module, choose M here. The module
+ will be called atl1c.
+
++source drivers/net/ethernet/atheros/ag71xx/Kconfig
++
+ endif # NET_VENDOR_ATHEROS
+--- a/drivers/net/ethernet/atheros/Makefile
++++ b/drivers/net/ethernet/atheros/Makefile
+@@ -2,6 +2,7 @@
+ # Makefile for the Atheros network device drivers.
+ #
+
++obj-$(CONFIG_AG71XX) += ag71xx/
+ obj-$(CONFIG_ATL1) += atlx/
+ obj-$(CONFIG_ATL2) += atlx/
+ obj-$(CONFIG_ATL1E) += atl1e/