aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch b/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch
deleted file mode 100644
index 464870c4fd..0000000000
--- a/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -685,6 +685,16 @@ config ATH79_MACH_CAP4200AG
- select ATH79_DEV_M25P80
- select ATH79_DEV_WMAC
-
-+config ATH79_MACH_MR900
-+ bool "OpenMesh MR900 board support"
-+ select SOC_QCA955X
-+ select ATH79_DEV_AP9X_PCI if PCI
-+ select ATH79_DEV_ETH
-+ select ATH79_DEV_GPIO_BUTTONS
-+ select ATH79_DEV_LEDS_GPIO
-+ select ATH79_DEV_M25P80
-+ select ATH79_DEV_WMAC
-+
- config ATH79_MACH_EAP7660D
- bool "Senao EAP7660D support"
- select SOC_AR71XX
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -76,6 +76,7 @@ obj-$(CONFIG_ATH79_MACH_JA76PF) += mach
- obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
- obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
- obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
-+obj-$(CONFIG_ATH79_MACH_MR900) += mach-mr900.o
- obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
- obj-$(CONFIG_ATH79_MACH_MYNET_N750) += mach-mynet-n750.o
- obj-$(CONFIG_ATH79_MACH_MYNET_REXT) += mach-mynet-rext.o
---- a/arch/mips/ath79/machtypes.h
-+++ b/arch/mips/ath79/machtypes.h
-@@ -67,6 +67,7 @@ enum ath79_mach_type {
- ATH79_MACH_HORNET_UB, /* ALFA Networks Hornet-UB */
- ATH79_MACH_MR600V2, /* OpenMesh MR600v2 */
- ATH79_MACH_MR600, /* OpenMesh MR600 */
-+ ATH79_MACH_MR900, /* OpenMesh MR900 */
- ATH79_MACH_MYNET_N600, /* WD My Net N600 */
- ATH79_MACH_MYNET_N750, /* WD My Net N750 */
- ATH79_MACH_MYNET_REXT, /* WD My Net Wi-Fi Range Extender */