aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch b/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
deleted file mode 100644
index 231b487b82..0000000000
--- a/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -254,6 +254,16 @@ config ATH79_MACH_WPE72
- select ATH79_DEV_USB
- select MYLOADER
-
-+config ATH79_MACH_DIR_505_A1
-+ bool "D-Link DIR-505-A1 support"
-+ select SOC_AR933X
-+ select ATH79_DEV_ETH
-+ select ATH79_DEV_GPIO_BUTTONS
-+ select ATH79_DEV_LEDS_GPIO
-+ select ATH79_DEV_M25P80
-+ select ATH79_DEV_WMAC
-+ select ATH79_NVRAM
-+
- config ATH79_MACH_DIR_600_A1
- bool "D-Link DIR-600 A1/DIR-615 E4 support"
- select SOC_AR724X
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -53,6 +53,7 @@ obj-$(CONFIG_ATH79_MACH_ARCHER_C7) += ma
- obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
- obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
- obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
-+obj-$(CONFIG_ATH79_MACH_DIR_505_A1) += mach-dir-505-a1.o
- obj-$(CONFIG_ATH79_MACH_DIR_600_A1) += mach-dir-600-a1.o
- obj-$(CONFIG_ATH79_MACH_DIR_615_C1) += mach-dir-615-c1.o
- obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
---- a/arch/mips/ath79/machtypes.h
-+++ b/arch/mips/ath79/machtypes.h
-@@ -37,6 +37,7 @@ enum ath79_mach_type {
- ATH79_MACH_CARAMBOLA2, /* 8devices Carambola2 */
- ATH79_MACH_DB120, /* Atheros DB120 reference board */
- ATH79_MACH_PB44, /* Atheros PB44 reference board */
-+ ATH79_MACH_DIR_505_A1, /* D-Link DIR-505 rev. A1 */
- ATH79_MACH_DIR_600_A1, /* D-Link DIR-600 rev. A1 */
- ATH79_MACH_DIR_615_C1, /* D-Link DIR-615 rev. C1 */
- ATH79_MACH_DIR_615_E4, /* D-Link DIR-615 rev. E4 */