aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch
index 828a3f9b9a..d02addb879 100644
--- a/target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch
+++ b/target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch
@@ -1,7 +1,7 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -104,6 +104,11 @@ config AR8216_PHY
- tristate "Driver for Atheros AR8216 switches"
+@@ -108,6 +108,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
select SWCONFIG
+config MICREL_PHY
@@ -14,9 +14,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -19,6 +19,7 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
+@@ -20,6 +20,7 @@ obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+obj-$(CONFIG_MICREL) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o